MDT 2012 Error – Invalid credentials: A specified logon session does not exist. It may already have been terminated (80070520)

Mondays! I swear, all the fun stuff happens on Mondays…

Well, I’ve officially put in my two weeks notice at my current job, and am heading to become a full-time System Center consultant! I’m super excited. That said, it has created a long list of “to-do’s” before I leave my current position, which is what I am now trying to dig myself out from under.

One of the tasks I had was getting a Windows 8.1 Image up on our MDT server. No one was asking for it, but that’s often how things go in Higher Education – no one will ask for it forever, then one day decide they need it tomorrow. To save my coworkers the trouble, I figured I’d just do it now.

Anyway, after capturing the image and setting up the new deployment task sequence, I did my first trial deployment. It worked just fine from the boot cd, but not when running ‘litetouch.vbs’ from the network share. I was perplexed.

Specifically, I was getting this error:

Invalid credentials: A specified logon session does not exist. It may already have been terminated ( 80070520 )

I double checked my connection credentials, and they were, in fact correct. What ended up being the issue is that, somehow, similarly to the issue I posted about earlier on this blog, my permissions on my Deployment Share got messed up again.

I removed, saved, and re-added all the necessary permissions on our deployment share, and all is now working again! A simple fix to a simple error.